|
질문 && 답변
RSS
제목 PHP7 & MariaDB 최신버전에서 설치 시 오류 나시는 분께(자문자답)
카테고리 오류
글쓴이 늘푸른사람(DWKIM) 작성시각 2016/09/06 15:49:10
댓글 : 1 추천 : 0 스크랩 : 0 조회수 : 5566

PHP 7 버전에 MariaDB 를 쓰시는 경우에는

install 시 DB접속에 계속 실패하는데요 ㅠㅠ php는 mysql_connect 를 지원하지 않기 때문에 아래와 같이 수정합니다.

이 경우는 아래 파일 수정하시면 접속 됩니다!

393~401 라인을 아래와 같이..

 

 $return                    = array();       

$return['version']         = '5.0';       

$return['version_require'] = '4.1'; //여기부터 서브쿼리 지원       

$return['version_usable']  = TRUE;       

$return['utf8']            = TRUE;       

$return['mysql']           = TRUE;       

$return['mysqli']          = TRUE;       

$return['innodb']          = TRUE;       

$return['trigger']         = TRUE;

그리고,

application/controllers/admin/install.php 여시고 403~460 라인  mysql 부분 주석처리하면 진행됩니다!

혹시 고생하실까봐 질답 게시판에 올립니다..ㅎㅎㅎ

 

 

 다음글 설치가 되기는 하는 건가요? (5)
 이전글 모바일 테마를 사용하지 않으려면 (2)

댓글

앗, 좋은 정보 감사합니다. php7 감안되도록 수정을 해봐야겠군요.
  • KangMin(배강민)
  • 작성시각 2016/09/06 21:25:50 추천 1
top
  새로운 메시지 : 0